VMware Workstation v12.0.0 Linux x64 on Ubuntu 15.10 doesn’t start

After dist-upgrade Ubuntu 15.04 to 15.10 VMware Workstation v12.0.0 Linux x64 on Ubuntu 15.10 doesn’t start. So I started googling and stumbled upon a Russian forum ultimately finding the solution.

Refrence to a Russian forum

http://forum.ubuntu.ru/index.php?topic=268032.0

 

Execute following commands in your terminal

$ export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH

 

$ echo /usr/lib/vmware/lib/libglibmm-2.4.so.1 | sudo tee -a /etc/ld.so.conf.d/LD_LIBRARY_PATH.conf

 

$ ldconfig

That’s it guys

[14-Nov-15] Update: After above mentioned workaround few programs like gnome-system-monitor and inkscape will not start.

Error “gnome-system-monitor: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgiomm-2.4.so.1: undefined symbol: _ZN4Glib11VariantTypeD1Ev”

Ref: https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1509729

To make vmware and other program work correctly follow this:

$ sudo vi /etc/ld.so.conf.d/LD_LIBRARY_PATH.conf

Delete line /usr/lib/vmware/lib/libglibmm-2.4.so.1

$ sudo vi /usr/bin/vmware

Add following line”export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1″ with out quotes, above “set -e”

this should work now, if it doesn’t; execute following command:

$ sudo apt-get install –reinstall libgtkmm-2.4-1v5

And Reboot your system.

Hope this helps

2 Replies to “VMware Workstation v12.0.0 Linux x64 on Ubuntu 15.10 doesn’t start”

Leave a Reply

Your email address will not be published. Required fields are marked *